Base de Datos

Instalación de Oracle

https://www.youtube.com/watch?v=BymSVgKqUEU Chicos vean este video que les va a ayudar a la instalación de los archivos de Oracle DB 21C. utilicen el sqldeveloper 23, por favor:

DB 21c Express Edition https://www.oracle.com/database/technologies/xe-downloads.html

SQL Developer 23.1.1 https://www.oracle.com/tools/downloads/sqldev-downloads-2311.html

Contraseña: Zacian1808

Error de E/S: The Network Adapter could not establish the connection

Si da el error "Error de E/S: The Network Adapter could not establish the connection (CONNECTION_ID=xxxxxx) Código de proveedor 17002"

Se debe abrir un CMD como administrador y ejecutar el comando

lsnrctl status

Si al ejecutar el comando muestra algo como

Conectándose a (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=DESKTOP-RJN8PLS.mshome.net)(PORT=1521))) TNS-12541: TNS:no hay ningún listener TNS-12560: TNS:error del adaptador de protocolo TNS-00511: No hay ningún listener 64-bit Windows Error: 61: Unknown error Conect�ndose a (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1521)))

Eso quiere decir que Oracle intentó buscar el listener pero no lo encontró.

Lo que se puede hacer es reiniciar el Listener desde CMD como administrado

lsnrctl stop

lsnrctl start

lsnrctl status

Si olvidaste la contraseña

Abre Símbolo del sistema como administrador y ejecuta:

sqlplus / as sysdba

Si entra correctamente, ejecuta esto:

ALTER USER system IDENTIFIED BY "Zacian1808" ACCOUNT UNLOCK CONTAINER=ALL;

Después ejecuta:

ALTER SYSTEM REGISTER;

Y sal:

EXIT;

Otro comandos útiles

Sirve para ver en qué contenedor de Oracle estás trabajando actualmente. Por ejemplo, puede mostrar: CDB$ROOT o XEPDB1.

SHOW CON_NAME;

En Oracle XE 21c existen contenedores. CDB$ROOT es el contenedor principal o raíz, y XEPDB1 es la base de datos pluggable donde normalmente se crean usuarios, tablas y objetos.

Sirve para cambiar la sesión actual al contenedor raíz CDB$ROOT.

ALTER SESSION SET CONTAINER = CDB$ROOT;

https://container-registry.oracle.com/ords/f?p=113:4:12009523575327:::4:P4_REPOSITORY,AI_REPOSITORY,AI_REPOSITORY_NAME,P4_REPOSITORY_NAME,P4_EULA_ID,P4_BUSINESS_AREA_ID:803,803,Oracle%20Database%20Express%20Edition,Oracle%20Database%20Express%20Edition,1,0&cs=3lvte9PCvs5cdHdHpjApPRNHjWS8B9CLWpPcgWvR42eKak3zyodZ8cWRjg2ANtPH_YJ-QXod6weBgXgM8_N0Ugw

Error - Docker failed to start

El error "Docker failed to start" al abrir Docker Desktop suele deberse a problemas de compatibilidad con WSL 2 en Windows, configuraciones corruptas o servicios no iniciados.

Pasos para corregirlo

  • Habilita WSL 2: Abre PowerShell como administrador y ejecuta wsl --install, luego wsl --set-default-version 2. Reinicia el PC.
Built with LogoFlowershow